Prev: [PATCH v2 2/3] mfd: MAX8998: Add interrupts support
Next: [PATCH 1/4] ACPI, APEI, Fix a typo of error path of apei_resources_request
From: Avi Kivity on 2 Aug 2010 03:50 On 07/27/2010 06:33 AM, Xiao Guangrong wrote: > Introduce spte_bits_lost() function to judge whether spte bits will > miss, it's more readable and can help us to cleanup code later > > Signed-off-by: Xiao Guangrong<xiaoguangrong(a)cn.fujitsu.com> > --- > arch/x86/kvm/mmu.c | 20 +++++++++++++++++--- > 1 files changed, 17 insertions(+), 3 deletions(-) > > diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c > index e10f2bd..dd6c192 100644 > --- a/arch/x86/kvm/mmu.c > +++ b/arch/x86/kvm/mmu.c > @@ -303,6 +303,20 @@ static u64 __xchg_spte(u64 *sptep, u64 new_spte) > #endif > } > > +static bool spte_bits_lost(u64 spte) > +{ > + if (!shadow_accessed_mask) > + return false; > + > + if (!is_shadow_present_pte(spte)) > + return false; > + > + if (spte& shadow_accessed_mask) > + return false; > + > + return true; > +} IMO spte_has_volatile_bits() is a clearer name, "lost" implies they are already gone. -- error compiling committee.c: too many arguments to function -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: Xiao Guangrong on 2 Aug 2010 04:00
Avi Kivity wrote: > On 07/27/2010 06:33 AM, Xiao Guangrong wrote: >> Introduce spte_bits_lost() function to judge whether spte bits will >> miss, it's more readable and can help us to cleanup code later >> >> Signed-off-by: Xiao Guangrong<xiaoguangrong(a)cn.fujitsu.com> >> --- >> arch/x86/kvm/mmu.c | 20 +++++++++++++++++--- >> 1 files changed, 17 insertions(+), 3 deletions(-) >> >> diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c >> index e10f2bd..dd6c192 100644 >> --- a/arch/x86/kvm/mmu.c >> +++ b/arch/x86/kvm/mmu.c >> @@ -303,6 +303,20 @@ static u64 __xchg_spte(u64 *sptep, u64 new_spte) >> #endif >> } >> >> +static bool spte_bits_lost(u64 spte) >> +{ >> + if (!shadow_accessed_mask) >> + return false; >> + >> + if (!is_shadow_present_pte(spte)) >> + return false; >> + >> + if (spte& shadow_accessed_mask) >> + return false; >> + >> + return true; >> +} > > IMO spte_has_volatile_bits() is a clearer name, "lost" implies they are > already gone. Yeah, it's the better name, will fix soon. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/ |