Prev: [PATCH 05/12] Add suspend\resume support for PV on HVM guests.
Next: [PATCH 1/1] X86: pci, fix section mismatch
From: Konrad Rzeszutek Wilk on 15 Jun 2010 09:50 > -static inline unsigned int max_nr_grant_frames(void) > +unsigned int gnttab_max_nr_grant_frames(void) > { > unsigned int xen_max = __max_nr_grant_frames(); > > @@ -444,6 +445,7 @@ static inline unsigned int max_nr_grant_frames(void) > return boot_max_nr_grant_frames; > return xen_max; > } > +EXPORT_SYMBOL_GPL(gnttab_max_nr_grant_frames); Prefix the name with 'xen_' ? That is a mouthfull thought: Xen Grant Table Max Nr Grant Frames. How about 'xen_gnttab_max_frames' ? -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: Jeremy Fitzhardinge on 15 Jun 2010 12:30 On 06/14/2010 10:20 PM, Konrad Rzeszutek Wilk wrote: >> -static inline unsigned int max_nr_grant_frames(void) >> +unsigned int gnttab_max_nr_grant_frames(void) >> { >> unsigned int xen_max = __max_nr_grant_frames(); >> >> @@ -444,6 +445,7 @@ static inline unsigned int max_nr_grant_frames(void) >> return boot_max_nr_grant_frames; >> return xen_max; >> } >> +EXPORT_SYMBOL_GPL(gnttab_max_nr_grant_frames); >> > Prefix the name with 'xen_' ? That is a mouthfull thought: > > Xen Grant Table Max Nr Grant Frames. How about 'xen_gnttab_max_frames' ? > Unfortunately the gnttab API is generally lacking xen_ prefixes. It's better to keep this consistent, and then maybe sort them all out together. J -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: Stefano Stabellini on 17 Jun 2010 11:50
On Tue, 15 Jun 2010, Jeremy Fitzhardinge wrote: > On 06/14/2010 10:20 PM, Konrad Rzeszutek Wilk wrote: > >> -static inline unsigned int max_nr_grant_frames(void) > >> +unsigned int gnttab_max_nr_grant_frames(void) > >> { > >> unsigned int xen_max = __max_nr_grant_frames(); > >> > >> @@ -444,6 +445,7 @@ static inline unsigned int max_nr_grant_frames(void) > >> return boot_max_nr_grant_frames; > >> return xen_max; > >> } > >> +EXPORT_SYMBOL_GPL(gnttab_max_nr_grant_frames); > >> > > Prefix the name with 'xen_' ? That is a mouthfull thought: > > > > Xen Grant Table Max Nr Grant Frames. How about 'xen_gnttab_max_frames' ? > > > > Unfortunately the gnttab API is generally lacking xen_ prefixes. It's > better to keep this consistent, and then maybe sort them all out together. > I renamed it to gnttab_max_grant_frames for now. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/ |