From: John on
I've installed two cisco 1841 routers with csu/dsu cards in them to
support
a closed circuit t1. The configuration for the serial port is as
follows:

Router A:
interface serial 0/0/0
ip address 192.168.1.1 255.255.255.0
ip access-group 101 in
ip access-group 102 out
encapsulation ppp
service-module t1 clock source internal
service-module t1 timeslots 1-24
crypto map myMap


Router B:
interface serial 0/0/0
ip address 192.168.1.2 255.255.255.0
ip access-group 101 in
ip access-group 102 out
encapsulation ppp
service-module t1 cablelength short 220ft
service-module t1 timeslots 1-24
cypto map myMap


Everything seems to work fine, except the serial connection goes down
for
30secs about every 30min. We had the ISP out there to test the line
and
they tried to sync up the oscillators with some magical machine, and
that
helped the timing a little bit, but we still see the problem.

Our guess at this point is that there is a hardware problem, and we are
considering swapping out both routers. Does anybody have any other
ideas at
this point that I can try? Or even commands I can use to test the line
and
narrow down the problem? I tried following the Cisco troubleshooting
guide
for t1 lines, but maybe I missed something.

Also, Router B is connected from the terminal to the serial port with a
cable that is roughly 140ft. Perhaps the cable is messing things up?

Thanks.

--

From: Ruairi Carroll on
On Sep 18, 5:12 pm, "John" <johnthomps...(a)hotmail.com> wrote:
> I've installed two cisco 1841 routers with csu/dsu cards in them to
> support
> a closed circuit t1.  The configuration for the serial port is as
> follows:
>
> Router A:
> interface serial 0/0/0
>   ip address 192.168.1.1 255.255.255.0
>   ip access-group 101 in
>   ip access-group 102 out
>   encapsulation ppp
>   service-module t1 clock source internal
>   service-module t1 timeslots 1-24
>   crypto map myMap
>
> Router B:
> interface serial 0/0/0
>   ip address 192.168.1.2 255.255.255.0
>   ip access-group 101 in
>   ip access-group 102 out
>   encapsulation ppp
>   service-module t1 cablelength short 220ft
>   service-module t1 timeslots 1-24
>   cypto map myMap
>
> Everything seems to work fine, except the serial connection goes down
> for
> 30secs about every 30min.  We had the ISP out there to test the line
> and
> they tried to sync up the oscillators with some magical machine, and
> that
> helped the timing a little bit, but we still see the problem.

Hi John, what kind of card are you using ?
- What does 'sh controller t1 0/0/0' look like, taken 4 times every 10
mins (ie: across a failure), do your slip seconds increment?

>
> Our guess at this point is that there is a hardware problem, and we are
> considering swapping out both routers.  Does anybody have any other
> ideas at
> this point that I can try?  Or even commands I can use to test the line
> and
> narrow down the problem?  I tried following the Cisco troubleshooting
> guide
> for t1 lines, but maybe I missed something.

A hard loop on both sides will tell you if this is a hardware problem
(assuming this is already done). I've found it helps if you loop at
the router, then loop at the CSU/DSU (ie: test the length of your
cable). Then loop at the remote CSU/DSU (test the full circuit). This
is quite invasive testing tbh...

Keep an eye on the counters from 'sh controller t1 0/0/0' to see
what's incrementing. Also keep an eye on the serial interface counters
also...

> Also, Router B is connected from the terminal to the serial port with a
> cable that is roughly 140ft.  Perhaps the cable is messing things up?

Could be, see above, looping the circuit at various points on the
line, usually helps narrow down what introduces your issue.

>
> Thanks.
>
> --

From: Thrill5 on
I'm leaning towards a clocking issue but I have no idea what a "closed
circuit T1" is, never heard of that before. Do you mean that this is a
point-to-point T1 between two locations? If it is, then clocking should be
external (or recovered) on both ends. The carrier provides the clocking on
a T1. You have one side as internal, and the other is external. The
internal side is getting out of sync every 30 minutes and the line is going
down.

"John" <johnthompson1(a)hotmail.com> wrote in message
news:h9080k$3u4$1(a)aioe.org...
> I've installed two cisco 1841 routers with csu/dsu cards in them to
> support
> a closed circuit t1. The configuration for the serial port is as
> follows:
>
> Router A:
> interface serial 0/0/0
> ip address 192.168.1.1 255.255.255.0
> ip access-group 101 in
> ip access-group 102 out
> encapsulation ppp
> service-module t1 clock source internal
> service-module t1 timeslots 1-24
> crypto map myMap
>
>
> Router B:
> interface serial 0/0/0
> ip address 192.168.1.2 255.255.255.0
> ip access-group 101 in
> ip access-group 102 out
> encapsulation ppp
> service-module t1 cablelength short 220ft
> service-module t1 timeslots 1-24
> cypto map myMap
>
>
> Everything seems to work fine, except the serial connection goes down
> for
> 30secs about every 30min. We had the ISP out there to test the line
> and
> they tried to sync up the oscillators with some magical machine, and
> that
> helped the timing a little bit, but we still see the problem.
>
> Our guess at this point is that there is a hardware problem, and we are
> considering swapping out both routers. Does anybody have any other
> ideas at
> this point that I can try? Or even commands I can use to test the line
> and
> narrow down the problem? I tried following the Cisco troubleshooting
> guide
> for t1 lines, but maybe I missed something.
>
> Also, Router B is connected from the terminal to the serial port with a
> cable that is roughly 140ft. Perhaps the cable is messing things up?
>
> Thanks.
>
> --
>


From: John on
Ruairi Carroll wrote:

> On Sep 18, 5:12�pm, "John" <johnthomps...(a)hotmail.com> wrote:
> > I've installed two cisco 1841 routers with csu/dsu cards in them to
> > support
> > a closed circuit t1. �The configuration for the serial port is as
> > follows:
> >
> > Router A:
> > interface serial 0/0/0
> > � ip address 192.168.1.1 255.255.255.0
> > � ip access-group 101 in
> > � ip access-group 102 out
> > � encapsulation ppp
> > � service-module t1 clock source internal
> > � service-module t1 timeslots 1-24
> > � crypto map myMap
> >
> > Router B:
> > interface serial 0/0/0
> > � ip address 192.168.1.2 255.255.255.0
> > � ip access-group 101 in
> > � ip access-group 102 out
> > � encapsulation ppp
> > � service-module t1 cablelength short 220ft
> > � service-module t1 timeslots 1-24
> > � cypto map myMap
> >
> > Everything seems to work fine, except the serial connection goes
> > down for
> > 30secs about every 30min. �We had the ISP out there to test the line
> > and
> > they tried to sync up the oscillators with some magical machine, and
> > that
> > helped the timing a little bit, but we still see the problem.
>
> Hi John, what kind of card are you using ?
> - What does 'sh controller t1 0/0/0' look like, taken 4 times every 10
> mins (ie: across a failure), do your slip seconds increment?
>
> >
> > Our guess at this point is that there is a hardware problem, and we
> > are considering swapping out both routers. �Does anybody have any
> > other ideas at
> > this point that I can try? �Or even commands I can use to test the
> > line and
> > narrow down the problem? �I tried following the Cisco
> > troubleshooting guide
> > for t1 lines, but maybe I missed something.
>
> A hard loop on both sides will tell you if this is a hardware problem
> (assuming this is already done). I've found it helps if you loop at
> the router, then loop at the CSU/DSU (ie: test the length of your
> cable). Then loop at the remote CSU/DSU (test the full circuit). This
> is quite invasive testing tbh...
>
> Keep an eye on the counters from 'sh controller t1 0/0/0' to see
> what's incrementing. Also keep an eye on the serial interface counters
> also...
>
> > Also, Router B is connected from the terminal to the serial port
> > with a cable that is roughly 140ft. �Perhaps the cable is messing
> > things up?
>
> Could be, see above, looping the circuit at various points on the
> line, usually helps narrow down what introduces your issue.
>
> >
> > Thanks.
> >
> > --

Hey guys.

Thanks for the input. The "closed circuit T1" that I have
is a point-to-point connection. The ISP told us to set
1 side as internal and one side to line (just like a back-
to-back configuration) because they have nothing on the
line.

If I do a show controllers ..., the hardware is as follows:
Hardware is GT96K with integrated T1 CSU/DSU. This is true
on both routers.

If I do a show interfaces serial 0/0/0, the input errors, CRC, frame,
and overrun erros are also increasing.

Sorry for the late reply, but I'm back in the office now. I can try
more later. Thanks again for the reply. Any more ideas?



--

From: Andrey Tarasov on
John wrote:

> Hey guys.
>
> Thanks for the input. The "closed circuit T1" that I have
> is a point-to-point connection. The ISP told us to set
> 1 side as internal and one side to line (just like a back-
> to-back configuration) because they have nothing on the
> line.
>
> If I do a show controllers ..., the hardware is as follows:
> Hardware is GT96K with integrated T1 CSU/DSU. This is true
> on both routers.
>
> If I do a show interfaces serial 0/0/0, the input errors, CRC, frame,
> and overrun erros are also increasing.
>
> Sorry for the late reply, but I'm back in the office now. I can try
> more later. Thanks again for the reply. Any more ideas?

I find "nothing on the line" claim highly suspicious. The only time you
would run into such situation is when T1 are provisioned over plain
copper runs directly to the same central office from both locations. In
every other case there is something on the line and this something does
provide clocking.
Have you tried to set both ends to "line"?

Regards,
Andrey.