From: David Rientjes on 8 Jun 2010 15:10 On Tue, 8 Jun 2010, KOSAKI Motohiro wrote: > Now has_intersects_mems_allowed() has own thread iterate logic, but > it should use while_each_thread(). > > It slightly improve the code readability. > These cleanups should be done on top of my oom killer rewrite instead, please work with others in their work instead of getting in the way of it time and time again. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: Minchan Kim on 16 Jun 2010 11:30 On Wed, Jun 16, 2010 at 08:35:15PM +0900, KOSAKI Motohiro wrote: > > Now has_intersects_mems_allowed() has own thread iterate logic, but > it should use while_each_thread(). > > It slightly improve the code readability. > > Signed-off-by: KOSAKI Motohiro <kosaki.motohiro(a)jp.fujitsu.com> Reviewed-by: Minchan Kim <minchan.kim(a)gmail.com> -- Kind regards, Minchan Kim -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: David Rientjes on 17 Jun 2010 00:30 On Thu, 17 Jun 2010, KOSAKI Motohiro wrote: > > Now has_intersects_mems_allowed() has own thread iterate logic, but > it should use while_each_thread(). > > It slightly improve the code readability. > > Reviewed-by: Minchan Kim <minchan.kim(a)gmail.com> > Signed-off-by: KOSAKI Motohiro <kosaki.motohiro(a)jp.fujitsu.com> I disagree that the renaming of the variables is necessary, please simply change the while (tsk != start) to use while_each_thread(tsk, start); -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: KOSAKI Motohiro on 21 Jun 2010 07:50 > On Thu, 17 Jun 2010, KOSAKI Motohiro wrote: > > > > > Now has_intersects_mems_allowed() has own thread iterate logic, but > > it should use while_each_thread(). > > > > It slightly improve the code readability. > > > > Reviewed-by: Minchan Kim <minchan.kim(a)gmail.com> > > Signed-off-by: KOSAKI Motohiro <kosaki.motohiro(a)jp.fujitsu.com> > > I disagree that the renaming of the variables is necessary, please simply > change the while (tsk != start) to use while_each_thread(tsk, start); This is common naming rule of while_each_thread(). please grep. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: David Rientjes on 21 Jun 2010 16:20 On Mon, 21 Jun 2010, KOSAKI Motohiro wrote: > > I disagree that the renaming of the variables is necessary, please simply > > change the while (tsk != start) to use while_each_thread(tsk, start); > > This is common naming rule of while_each_thread(). please grep. > I disagree, there's no sense in substituting variable names like "tsk" for `p' and removing a very clear and obvious "start" task: it doesn't improve code readability. I'm in favor of changing the while (tsk != start) to while_each_thread(tsk, start) which is very trivial to understand and much more readable than while_each_thread(p, tsk). With the latter, it's not clear whether `p' or "tsk" is the iterator and which is the constant. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
|
Next
|
Last
Pages: 1 2 Prev: oom: kill useless debug print Next: x86, UV: calculate BAU destination timeout |