Prev: mac8390: fix pr_info() calls and change return code
Next: blkio: Initialize blkg->stats_lock for the root cfqg too
From: KOSAKI Motohiro on 16 Apr 2010 01:40 > > + /* > > + * If we need a large contiguous chunk of memory, or have > > + * trouble getting a small set of contiguous pages, we > > + * will reclaim both active and inactive pages. > > + */ > > + if (sc->order > PAGE_ALLOC_COSTLY_ORDER) > > + sc->lumpy_reclaim = 1; > > + else if (sc->order && priority < DEF_PRIORITY - 2) > > + sc->lumpy_reclaim = 1; > > + else > > + sc->lumpy_reclaim = 0; > > How about making new function for readability instead of nesting else? > int is_lumpy_reclaim(struct scan_control *sc) > { > .... > } > > If you merge patch reduced stack usage of reclaim path, I think it's > enough alone scan_control argument. > It's just nitpick. :) > If you don't mind, ignore, please. Good opinion. I don't hope introduce the dependency of "reduced stack usage" series. but I agree that I'll push your proposal later and separately. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
From: Andrew Morton on 16 Apr 2010 17:20
On Fri, 16 Apr 2010 12:16:18 +0900 (JST) KOSAKI Motohiro <kosaki.motohiro(a)jp.fujitsu.com> wrote: > If vmscan is under lumpy reclaim mode, it have to ignore referenced bit > for making contenious free pages. but current page_check_references() > doesn't. > > Fixes it. > > Signed-off-by: KOSAKI Motohiro <kosaki.motohiro(a)jp.fujitsu.com> > --- > mm/vmscan.c | 32 +++++++++++++++++--------------- > 1 files changed, 17 insertions(+), 15 deletions(-) > > diff --git a/mm/vmscan.c b/mm/vmscan.c > index 3ff3311..13d9546 100644 > --- a/mm/vmscan.c > +++ b/mm/vmscan.c > @@ -77,6 +77,8 @@ struct scan_control { > > int order; > > + int lumpy_reclaim; > + Needs a comment explaining its role, please. Something like "direct this reclaim run to perform lumpy reclaim"? A clearer name might be "lumpy_relcaim_mode"? Making it a `bool' would clarify things too. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo(a)vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/ |